728x90
문제
n이 주어졌을 때, 1부터 n까지 합을 구하는 프로그램을 작성하시오.
입력
첫째 줄에 n (1 ≤ n ≤ 10,000)이 주어진다.
출력
1부터 n까지 합을 출력한다.
예제 입력 1
3
예제 출력 1
6
CODE
const readline = require('readline');
const rl = readline.createInterface({
input: process.stdin,
output: process.stdout,
});
rl.on('line', function (line) {
const n = Number(line);
let sum = 0;
for (let i = 1; i <= n; i++) {
sum += i;
}
console.log(sum);
rl.close();
}).on('close', function () {
process.exit();
});
'ALGORITHM > 백준 With Node.js' 카테고리의 다른 글
[백준] 2741번 / N 찍기 / Node.js (0) | 2021.04.21 |
---|---|
[백준] 15552번 / 빠른 A+B / Node.js (0) | 2021.04.21 |
[백준] 10950번 / A+B - 3 / Node.js (0) | 2021.04.21 |
[백준] 2739번 / 구구단 / Node.js (0) | 2021.04.21 |
[백준] 2884번 / 알람 시계 / Node.js (0) | 2021.04.20 |
댓글