728x90
문제
두 정수 A와 B를 입력받은 다음, A×B를 출력하는 프로그램을 작성하시오.
입력
첫째 줄에 A와 B가 주어진다. (0 < A, B < 10)
출력
첫째 줄에 A×B를 출력한다.
예제 입력 1
1 2
예제 출력 1
2
예제 입력 2
3 4
예제 출력 2
12
CODE
// readline 모듈을 import
const readline = require('readline');
// 인터페이스 객체 생성
// process의 입출력 스트림을 input과 output에 할당
const rl = readline.createInterface({
input: process.stdin,
output: process.stdout,
});
rl.on('line', function (line) {
const input = line.split(' ');
const result = Number(input[0]) * Number(input[1]);
console.log(result);
rl.close();
}).on('close', function () {
process.exit();
});
Comment
'readline을 이용하는 방식' 참조
References
velog.io/@yujo/node.js%ED%91%9C%EC%A4%80-%EC%9E%85%EB%A0%A5-%EB%B0%9B%EA%B8%B0
'ALGORITHM > 백준 With Node.js' 카테고리의 다른 글
[백준] 10869번 / 사칙연산 / Node.js (0) | 2021.04.19 |
---|---|
[백준] 1008번 / A/B / Node.js (0) | 2021.04.19 |
[백준] 1001번 / A-B / Node.js (0) | 2021.04.19 |
[백준] 1000번 / A+B / Node.js (0) | 2021.04.19 |
[백준] 10172번 / 개 / Node.js (0) | 2021.04.19 |
댓글